Notifications
Clear all

ultimo valor de um intervalo  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
12/05/2010 8:45 am  

Boa tarde, estou precisando de um formula que me retorne o ultimo valor de um intervalo e não o maior, pois o intervalo que eu estou ultilizando tem muitas celulas que estão em branco dentro de um periodo.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


Citar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
12/05/2010 9:09 am  

=ÍNDICE(intervalo;CONT.VALORES(intervalo))

ex: =ÍNDICE(A2:A50;CONT.VALORES(A2:A50))

*Obs: Se for uma data, talvez vc precise formatar a célula!!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
12/05/2010 9:28 am  

NÃO FUNCIONOU A CELULA FICOU ASSIM

"-"

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
12/05/2010 6:20 pm  

Desculpe...esqueci de colocar a função INDICE() antes!!! My bad :?

O correto seria =ÍNDICE(A1:A100;MÁXIMO(SE(A1:A100<>"";LIN(A1:A100)))) ctrl+shift+enter

Agora se vc quiser, pode ser feito usando uma coluna auxliar e um PROCV()

Segue exemplo da plan com PROCV() > download/file.php?id=388

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
13/05/2010 4:34 am  

Leonardo, bom dia esta formula do Indice e muito interessante mais não esta funcionando, faz alguns teste nela ai.

estou estou aplicando ela aqui em colunas e não em linhas, quando ultilizo esta formula do indice so aparece o ultimo valor do intervalo se na ultima celula do intervalo que coloquei na formula estiver com algum valor se não tiver fica um zero ele não me retorna as celulas alteriores.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
13/05/2010 8:24 am  

Teste essa fórmula do INDICE() no openoffice e nao funfa mesmo, mas no Excel parece q ta OK!!!
Vc poderia mandar um exemplo da plan e nela mesmo vc especificar q em tal celula vc gostaria q retornasse tal valor, pode ser?

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
13/05/2010 10:37 am  

http://rapidshare.com/files/386906793/A ... l.xls.html

eu quero que na coluna AP me retorner o ultimo valor das colunas anteriores.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
13/05/2010 1:18 pm  

Ah sim!!!
Quando se trata na horizontal como vc disse, usamos a função COL() ao invez de LIN() .....ficando assim:
=ÍNDICE(A4:AO4;MÁXIMO(SE(D4:AO4<>"";COL(D4:AO4))))

*Obs: Testei no OpenOffice 3.1 e as fórmulas matriciais funcionaram perfeitamente!!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
13/05/2010 1:59 pm  

Muito obrigado funcionou perfeitamente, você poderia dar uma explicação breve de como esta formula esta funcionando.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/05/2010 9:32 am  

Seguindo a imagem podemos "LER" a primeira fórmula assim!!!
Se o intervalo A1:k1 for diferente de nada(vazio) retorne o maior número da coluna...( no exemplo é coluna I ou coluna 9)

Na segunda fórmula é o mesmo q usarmos =ÍNDICE(A1:K1;9) que vai dar o resultado 47!!!

Caso vc queira alguns exemplo sobre o q podemos fazer com as fórmulas matriciais, de uma olhada nesses dois links!!!!
viewtopic.php?f=28&t=146
viewtopic.php?f=28&t=145

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
23/09/2011 7:48 am  

Eu estou tendo o mesmo problema, mas as suas fórmulas, nenhuma funcionou.
retornava a mensagem #VALOR!

Tipo eu tenho que fazer que na última célula de cada coluna apareça o último valor adicionado.

Não tem uma fórmula utilizando o SE ou algo mais rápido e pratico não?

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
23/09/2011 8:00 am  

Tenta essa fórmula Toxic:

=DESLOC(A1;SOMARPRODUTO(MÁXIMO((A2:A62<>0)*(A2:A62<>"")*(LIN(A2:A62))))-1;0)

Qualquer coisa da o grito.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
23/09/2011 8:20 am  

Muito obrigado... deu certinho. Vlw mesmo!
Uma coisa simples... tem jeito de vc me explicar como que ela funciona pra se eu quiser utilizá-la algum outro dia em outra planilha eu saber exatamente como proceder?

desde já agradeço a ajuda.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: