Notifications
Clear all

=Se com mais de 7 condições (Excel 2003)  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
10/07/2009 2:48 pm  

Caso preciso ou queira usar a função SE com mais de 7 condições que é o limite do excel 2003 combine a função SE mais CONCATENA (&)

Exemplo:

=SE(A1="A";1;"")&SE(A1="B";2;"")&SE(A1="C";3;"")&SE(A1="D";4;"")&SE(A1="E";5;"")&SE(A1="F";6;"")&SE(A1="G";7;"")&SE(A1="H";8;"")&SE(A1="I";9;"")&SE(...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


Citar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
10/07/2009 3:20 pm  

E se não forem textos, forem números, vc pode optar por usar o + e zeros ao invés de ""

=SE(A1="A";1;0)+SE(A1="B";2;0)+SE(A1="C";3;0)+SE(A1="D";4;0)+SE(A1="E";5;0)+SE(A1="F";6;0)+SE(A1="G";7;0)+SE(A1="H";8;0)+SE(A1="I";9;0)+SE(...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
10/07/2009 11:07 pm  

Tem uma outra situação tb q (se não me engano) pode-se usar a função ESCOLHER. O Galvão postou lá no Orkut, mas não consegui achar pra colocar aqui...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
13/10/2009 6:14 pm  

.
Diante de um monte de SE ... acho mais "limpo" relacionar as hipóteses num canto da plan e usar procv ou índice/corresp ...
.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: