Notifications
Clear all

Qtd de compras de um cliente  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
07/06/2010 12:59 pm  

Estou com um problema, quero fazer com que o excel busque na planilha os seguintes dados, quantas vezes um cliente fez uma compra, o valor total de todas as compras e a última vez que ele comprou. Consegui uma fórmula para contar o número de itens que ele comprou.

Segue o link para download da planilha
http://www.4shared.com/file/yDlVkMvE/Co ... _2010.html

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
08/06/2010 12:11 pm  

Acredito q de pra fazer com um SOMARPRODUTO() ou uma SOMA matricial

Tem como vc postar um exemplo, tipo: na celula da plan tal, teria q ter o resultado tal pq na planilha contou os valores das celulas tais!!!
Mais ou menos assim!!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
08/06/2010 6:05 pm  

Nessa planilha aí não consta clientes... :?: ... :shock:

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
09/06/2010 5:33 am  

Leo,

Através do SOMARPRODUTO eu consegui que ele fizesse a soma total das compras dos clientes, só q se eu for comparar manualmente selecionando os filtros o valor dado é diferente do valor real, n consigo entender o porque. O esquema seria mais ou menos o seguinte:

Na coluna "Frequência de Compras" tem q ter quantas vezes o cliente fez uma compra, eu usei o CONT.SES, só q eu n sei como fazer para ele contar apenas uma vez, ja q as notas fiscais são repetidas pois é colocado para cada item q foi vendido.
Na valor total tem q aparecer o valor total das compras dos clientes, eu usei a seguinte fórmula
=SOMARPRODUTO(('Nota Fiscais Emitidas'!$D$18:$D$60842=A5)*('Nota Fiscais Emitidas'!$C$18:$C$60842="Venda de Mercadoria")*('Nota Fiscais Emitidas'!$M$4:$M$60828))
Mas como eu disse antes n retorna o valor exato

E na coluna Última compra tem q aparecer quando q foi a última compra q o cliente fez, tentei um PROCV mas como a maioria dos clientes fizeram várias compras n dá certo, teria q ser de um modo q ele pegasse o maior valor disponível.

Rafael todos os dados estão na plan 'Notas Fiscais Emitidas', só da uma olhadinha q vc encontra.

http://www.4shared.com/document/1cGsdiC ... _-_ve.html

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
09/06/2010 7:02 am  

Usando o Filtro, vc tera q colocar uma coluna auxiliar....
Fiz um exemplo na Plan "Ref. Cliente - Cidade" na celula D2 D3 e D4

*Obs: Sua planilha esta muuuuiiito lenta...evite colocar formulas muito longas como =SOMARPRODUTO(('Nota Fiscais Emitidas'!$D$18:$D$60842=A5)

segue download da plan > download/file.php?id=427

*Dica: Se vc aprender a usar a ferramenta lista no menu dados, será de grande ajuda para a sua plan....pois ela tem a vantagem de aumentar a referencia de sua formula....
Ex: Digamos q vc tenha uma coluna A1:A10 preenchidas com valores.....e em outra plan (ou na mesma) uma formula =SOMA(A1:A10) se vc aumentar os valores da coluna A a formula aumentara a referencia sozinha, tipo =SOMA(A1:A11)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
09/06/2010 10:54 am  

Leo,

N entendi direito o q vc fez lá, mas valeu pela dica das listas e o fato das fórmulas essa planilha era outra pessoa q tava fazendo, ta cheia de erro até, mas ja mudei as referencias para numeros menores.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
09/06/2010 11:12 am  

Seria mais ou menos assim!!!

Sua formula era.....
=SOMARPRODUTO(('Nota Fiscais Emitidas'!$D$18:$D$60842=A5)*('Nota Fiscais Emitidas'!$C$18:$C$60842="Venda de Mercadoria")*('Nota Fiscais Emitidas'!$M$4:$M$60828))

No lugar de A5 coloquei a celula D2 da plan Ref. Cliente - Cidade
No lugar de Venda de Mercadoria coloquei a celula D3 da plan Ref. Cliente - Cidade

Depois é só filtrar na planilha Nota Fiscais Emitidas para ver os totais filtrados!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
09/06/2010 11:59 am  

Neste caso falta automatizar a buscar da data da última compra...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
09/06/2010 12:52 pm  

Leo e Rafa,

Valeu pela ajuda ai, so queria saber como vc fez aquilo Rafa nunca tinha visto antes... hehe acho q ainda tem muita coisa pra eu aprender de Excel.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
09/06/2010 12:58 pm  

É tabela dinâmica. Toda vez que vc acrescentar algo na planilha é necessário atualizar a tabela dinâmica... como? em qualquer célula na tabela clique com o botão direito e escolha atualizarar tabela dinâmica.

Bom, acho que as duas solicitações iniciais a tabela resolve, falta só a parte da data da última compra. Acho que o Léo tira de letra. ;)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
09/06/2010 7:00 pm  

Para pegar a última data, você pode usar a função PROCV.

Porém, os dados da planilha "Nota Fiscais Emitidas" deverão estar classificados da seguinte forma:

Coluna Cliente de A - Z.
Coluna Data do maior para o menor.

Pois a PROCV, quando faz pesquisas em tabelas que contenham valores repetidos, traz o primeiro valor encontrado ignorando as demais repetições.

Veja um exemplo para a fórmula:

=PROCV(A2; 'Nota Fiscais Emitidas'!$D$4:$E$2036; 2; 0)

[]s
JLM
Santo André - SP

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
10/06/2010 8:57 am  

JLM,

Neste caso dele existem nomes repetidos e nem sempre o primeiro nome refere-se a última data.
Neste caso deve ser algo mais que apenas a função PROCV.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/06/2010 8:11 am  

Olá pessoal, acho q arranjei um jeito de pegar a data da última compra, mas acho tb q estou fazendo alguma coisa errada. Seria através da fórmula "BDMÁX". Nela eu coloquei o seguinte:

=BDMÁX('Nota Fiscais Emitidas'!B4:E2254;"'Nota Fiscais Emitidas'!E4:E2254";Natureza="Venda de Mercadoria")

Onde Natureza é a coluna Natureza em Notas Fiscais Emitidas. Olhem aí pra ver o q eu fiz de errado.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/06/2010 9:02 am  

Nossa...eu achei q tinha encerrado o topico :oops:

se vc tiver usando a coluna auxiliar q postei no ultimo exemplo vc pode usar a formula
=MÁXIMO(SE('Nota Fiscais Emitidas'!BP4:BP2245<>0;'Nota Fiscais Emitidas'!E4:E2245)) finalizar com shift+ctrl+enter ao inves de somente enter

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: