Notifications
Clear all

procurar por código ou nome na mesma célula  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
28/05/2010 10:51 am  

Boa tarde!

Tenho uma planilha com as seguinte colunas:

A1= Código

B1= Funcionário

C1= Cargo

Na coluna D1 quero criar um campo de pesquisa, mas que ele me mostre o cargo do funcinário tanto pelo código, quanto pelo nome do funcionário. Já tentei fazer ÍNDICE + CORRESP com um PROCV concatenado, mas não deu certo, o que eu faço...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


Citar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
28/05/2010 12:56 pm  

Vc pode usar o & para concatenar as duas fórmulas
=SE(ÉERROS(CORRESP(E2;A:A;0));"";ÍNDICE(C:C;CORRESP(E2;A:A;0)))&SE(ÉERROS(CORRESP(E2;B:B;0));"";ÍNDICE(C:C;CORRESP(E2;B:B;0)))

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
29/05/2010 7:11 am  

Leo, muito obrigado cara, voce é fera mesmo, valeu

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
29/05/2010 7:24 am  

;)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: