Notifications
Clear all

Problemas com a Função "Procv"  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
22/05/2010 8:22 am  

a Planilha é esta:
http://www.imagebam.com/image/c1f41b81570441
Quero Achar o valor Recebidos do mês de Janeiro através desta função
"Procv"
Eu fiz assim:
=PROCV(D120;B6:B13;2). mas deu erro (#N/D)
Como resolvo isso?

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
22/05/2010 10:58 am  

Leo,
Vc está usando o PROCV de forma errada.
Vc está querendo Achar o valor Recebidos onde não tem essa palavra. A coluna B6 a B13 não é o suficiente. O procv precisa de uma matriz e precisa ter a referência para buscar determinado valor. Ou seja, seu intervalo deveria ser A3:B13 e obrigatoriamente na coluna A deve ter a palavra RECEBIDOS que vc tem na célula D120. Logo, o procv vai na primeira coluna do intervalo A3:B13 vai procurar a palavra Recebidos, pegar o valor que corresponde a essa palavra (que está na segunda coluna do intervalo A3:B13) e colocar no local onde vc digitou a fórmula.

Se está confuso de entender tente fazer o seguinte:

- Na célula A6 onde está escrito a palavra salário escreva a palavra Recebidos.

- Na célula E120 coloque o seguinte:
=PROCV(D120;A13:B13;2;falso)

Depois creio que vc vai entender, caso contrário dê mais uma analisada na sintaxe do PROCV ou abra novo tópico para tirar qualquer dúvida em relação ao PROCV.
Te apostilas na biblioteca que podem te ajudar melhor.

Espero ter ajudado.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
22/05/2010 6:09 pm  

Leo,
Vc está usando o PROCV de forma errada.
Vc está querendo Achar o valor Recebidos onde não tem essa palavra. A coluna B6 a B13 não é o suficiente. O procv precisa de uma matriz e precisa ter a referência para buscar determinado valor. Ou seja, seu intervalo deveria ser A3:B13 e obrigatoriamente na coluna A deve ter a palavra RECEBIDOS que vc tem na célula D120. Logo, o procv vai na primeira coluna do intervalo A3:B13 vai procurar a palavra Recebidos, pegar o valor que corresponde a essa palavra (que está na segunda coluna do intervalo A3:B13) e colocar no local onde vc digitou a fórmula.

Se está confuso de entender tente fazer o seguinte:

- Na célula A6 onde está escrito a palavra salário escreva a palavra Recebidos.

- Na célula E120 coloque o seguinte:
=PROCV(D120;A13:B13;2;falso)

Depois creio que vc vai entender, caso contrário dê mais uma analisada na sintaxe do PROCV ou abra novo tópico para tirar qualquer dúvida em relação ao PROCV.
Te apostilas na biblioteca que podem te ajudar melhor.

Espero ter ajudado.

Leo,
Vc está usando o PROCV de forma errada.
Vc está querendo Achar o valor Recebidos onde não tem essa palavra. A coluna B6 a B13 não é o suficiente. O procv precisa de uma matriz e precisa ter a referência para buscar determinado valor. Ou seja, seu intervalo deveria ser A3:B13 e obrigatoriamente na coluna A deve ter a palavra RECEBIDOS que vc tem na célula D120. Logo, o procv vai na primeira coluna do intervalo A3:B13 vai procurar a palavra Recebidos, pegar o valor que corresponde a essa palavra (que está na segunda coluna do intervalo A3:B13) e colocar no local onde vc digitou a fórmula.

Se está confuso de entender tente fazer o seguinte:

- Na célula A6 onde está escrito a palavra salário escreva a palavra Recebidos.

- Na célula E120 coloque o seguinte:
=PROCV(D120;A13:B13;2;falso)

Depois creio que vc vai entender, caso contrário dê mais uma analisada na sintaxe do PROCV ou abra novo tópico para tirar qualquer dúvida em relação ao PROCV.
Te apostilas na biblioteca que podem te ajudar melhor.

Espero ter ajudado.

Ok !!
Entendido
Pensei q dava pra achar este valor mesmo sem a Palavra em questão. Agradeço a força.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
23/05/2010 10:16 am  

Boa tarde, Léo.

Realmente não dá pra fazer dessa forma que vc imaginou, mas existem outras formas. Dependendo do que vc precisa na planilha podemos conseguir uma solução com outra alternativa para que vc deixe sua planilha mais automática e prática.

Qualquer coisa, estamos à disposição. Basta postar a planilha e explicar.

Abraços,

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: