Notifications
Clear all

Planilha Comparar 2 Colunas:  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
25/09/2009 5:03 pm  

Preciso ajuda para comparar Coluna A (estoque Parceiro) com a Coluna B (estoque Master).

Gostaria que criasse formulas para ter coluna C

Se Número na Coluna A tiver mesmo valor de Número Coluna B então = número A (verde)
Se número tiver apenas coluna A = número A (amarelo)
Se número tiver apenas na coluna B = Número B (vermelho)

Estoque é apenas números de 12 digitos que são números dos equipamentos:
168876453234
168097234876
.
.
Se alguém tiver alguma parecida e quiser colocar link para eu baixar eu agradeço.
:mrgreen:

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


Citar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
25/09/2009 7:11 pm  

Ve se é assim!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
25/09/2009 8:10 pm  

Ve se é assim!!!

Perfeito!

Vai me ajudar bastante...

vlw

:mrgreen:

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
29/03/2010 3:13 am  

Opa, aqui estou eu novamente.

Certo agora precisando novamente de ajuda.

Tenho 1 controle de estoque com aproximadamente 1000 números, mais alguns deles estão repetidos:

168876453234
168097234876
.
.

Coluna é composta de números de 12 dígitos conforme exemplo acima. Eu preciso ver quais estão repetidos para poder retirar, assim posso jogar na primeira planilha que eu solicitei aqui.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
29/03/2010 7:55 am  

Opa, aqui estou eu novamente.

Certo agora precisando novamente de ajuda.

Tenho 1 controle de estoque com aproximadamente 1000 números, mais alguns deles estão repetidos:

168876453234
168097234876
.
.

Coluna é composta de números de 12 dígitos conforme exemplo acima. Eu preciso ver quais estão repetidos para poder retirar, assim posso jogar na primeira planilha que eu solicitei aqui.

Caso de BO, já resolvi aqui. :lol:

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
29/03/2010 8:30 am  

Ve se é assim!!!

Leonardo a planilha tá enorme vem apresentando alguns alguns erros.
Tipo na Formúla original:
=SE(LIN()-2<CONT.VALORES($B$2:$B$100);B2;SE(LIN()-2<CONT.VALORES($B$2:$C$100);DESLOC($C$1;LIN()-CONT.VALORES($B$2:$B$100)-1;0;1;1);""))
Então modifiquei ela assim, aumentando valores de 100 para 1500:
=SE(LIN()-2<CONT.VALORES($B$2:$B$1500);B2;SE(LIN()-2<CONT.VALORES($B$2:$C$1500);DESLOC($C$1;LIN()-CONT.VALORES($B$2:$B$1500)-1;0;1;1);""))

Mais ao colar númeração dos aparelhos dentro da planilha não está dando certo e um valor verde que está nas 2 colunas se repete no final ficando vermelho ou então sem cor nenhuma. O que estou errando?
:shock:

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
29/03/2010 5:18 pm  

Para as cores se alterarem é preciso usar a formatação condicional (Formatar / Formatação condicional)!!!
Veja a imagem!!!

Quanto ao erro....talvez seja o seguinte....
Repare q a formula começa com...
=SE(LIN()-2<CONT.VALORES(
esse -2 faz a formula funcionar se ela começar na linha 2....se vc começar a usar a formula na linha 7 (por exemplo) ela ficaria assim...
=SE(LIN()-7<CONT.VALORES($B$2:$B$1500);B2;SE(LIN()-7<CONT.VALORES($B$2:$C$1500);DESLOC($C$1;LIN()-CONT.VALORES($B$2:$B$1500)-1;0;1;1);""))

Se nao for isso...da um tok!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
30/03/2010 12:35 pm  

Não deu certo.
Continua com erro, dá criar exemplo com 1500 linhas a original tem 100 linhas, mais quando aumentei para 1500 alguma coisa deu erro, veja exemplo.

http://rapidshare.com/files/370038906/Testando.xls.html

:?:

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
30/03/2010 4:47 pm  

Testei aki e deu certo!!!
segue a plan de exemplo....veja se é assim msm!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: