Notifications
Clear all

Função PROCV  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
17/05/2010 12:35 pm  

Gostaria de saber se há um meio de fazer o excel procurar se baseando em dois valores ao invés de um só. Estou querendo fazer uma planilha com a quantidade de produtos vendidos de acordo com o mês, então não dá certo colocar para ele pesquisar pelo produto nem pelo mês, já que ambos se repetem...

Já agradeço pela ajuda.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
17/05/2010 1:22 pm  

Acredito q nao seja dificil.....tem como postar uma copia da planilha?

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
17/05/2010 1:31 pm  

Segue a planilha

http://www.4shared.com/file/yDlVkMvE/Co ... _2010.html

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
17/05/2010 2:04 pm  

Veja se é uma dessas!!!!

=SOMARPRODUTO(('Produtos (Venda)'!$A$2:$A$100=A3)*1)
vai CONTAR quantos serviços foi feito no mês q estiver em A3

=SOMARPRODUTO(('Produtos (Venda)'!$A$2:$A$100=A3)*('Produtos (Venda)'!$D$2:$D$100))
vai SOMAR quantos produtos foram feitos no mês q estiver em A3 com a quantidade desses produtos na coluna D

=SOMARPRODUTO(('Produtos (Venda)'!$A$2:$A$100=A3)*('Produtos (Venda)'!$E$2:$E$100))
vai SOMAR o valor dos produtos q foram feitos no mês q estiver em A3

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
18/05/2010 5:29 am  

A última fórmula foi útil, as outras não, pois o que eu quero é fazer uma busca que não se baseie apenas em um parâmetro, como dá para ver na planilha de 'Produtos (Venda)' o código se repete mas nunca eu vou ter duas vezes o mesmo produto e o mesmo mês ao mesmo tempo, isso seria mais para facilitar meu trabalho para não ter que ficar editando a PROCV.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
18/05/2010 8:56 am  

Q bom....então deu certo?

Se precisar estamos aew!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: