Notifications
Clear all

Fórmula para Juros Compostos  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
04/01/2010 8:20 am  

Amigos,

Primeiramente gostaria de desejar um ótimo 2010 a todos!

Gostaria de saber se existe alguma fórmula no excel para o cálculo de juros compostos (juros sobre juros) ou se alguém já desenvolveu alguma fórmula para esta finalidade.

Atualmente estou utilizando o seguinte método para o cálculo (No exemplo cada célula corresponde à uma rentabilidade mensal):

=(1+E40)*(1+E41)*(1+E42)*(1+E43)*(1+E44)*(1+E45)*(1+E46)*(1+E47)*(1+E48)*(1+E49)*(1+E50)*(1+E51)*(1+E52)*(1+E53)*(1+E54)*(1+E55)*(1+E56)*(1+E57)*(1+E58)*(1+E59)*(1+E60)*(1+E61)-1

Como podem ver, em menos de 2 anos de período a fórmula já está bem grande.

Um outro método é criar um índice. Por exempo, determina-se o número 100 e vai atualizando (fatorando) mês a mês esse índice. É menos trabalhoso mas ocupa maior espaço.

Seria útil uma fórmula em que fosse possível:

(1) Determinar a quantidade de células (número de meses - rentabilidades mensais)
(2) Selecionando as células a fórmula já traria o retorno composto através de um dos métodos descritos acima.

Alguém poderia dar uma ajuda?

Grande Abraço!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
04/01/2010 11:17 am  

Olá Henrique!!!!

Não li sua postagem inteira mas veja se é algo assim!!!
viewtopic.php?f=28&t=157

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
04/01/2010 12:18 pm  

Fala Léo!

Estas fórmulas não funcionam pois a rentabilidade (taxa) nos períodos é diferente. Se a taxa fosse constante seria mole.

Seria uma fórmula que soubesse identificar as diferentes rentabilidades em um dado período e retornasse o juros compostos.

Ex (Método 01):

Mês 1: +2,35%
Mês 2: -0,58%
Mês 3: +1,58%
Mês 4: -2,49%
Mês 5: +5,48%

Juros compostos = (1+0,0235)*(1-0,0058)*(1+0,0158)*(1-0,00249)*(1+0,0548)-1 = 6,31%

Ex. (Método 02) - Supondo as mesmas rentabilidades mensais:

Mês 0: 100
Mês 1: =100+100*2,35% = 102,35
Mês 2: =102,35+102,35*-0,58% = 101,76
Mês 3: =101,76+101,76*1,58% = 103,36
Mês 4: =103,36+103,36*-2,49% = 100,79
Mês 5: =100,79+100,79*5,48% = 106,31

Juros compostos = 106,31 / 100,00 -1 = 6,31%

Se uma fórmula fosse capaz de gerar o resultado (6,31%) apenas considerando o período (5 meses) e os juros mensais seria ótimo e evitaria um gasto maior de tempo e de espaço na planilha.

Abraços!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
04/01/2010 12:43 pm  

Olá amigos!

Consegui uma solução através de uma colaboração.

A fórmula é uma matricial.

{=MULT(B1:B5+1)-1}

O resultado é semelhante aos outros dois métodos!

Grande Abraço!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
05/01/2010 10:21 pm  

Uma outra opção, sem o uso de função matricial: =SOMARPRODUTO(MULT(B1:B5+1))-1
[ ]s

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
06/01/2010 7:06 am  

Perfeito Adilson!

Confesso que a fórmula matricial estava me atrapalhando um pouco. Agora está bem melhor!

Nem preciso dizer que sou um fã seu e que acompanho o seu blog.

Muito obrigado pelas dicas!

Grande Abraço!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
11/11/2010 8:20 am  

Olá amigos!

Retomando este tema mais de 1 ano depois:

Como faço para usar esta função no VBA:

=SOMARPRODUTO(MULT(B1:B5+1))-1

Tentei deste modo:

Application.worsheetfunction.SOMARPRODUTO(MULT(B1:B5+1))-1

Porém, não obtive sucesso...

É possível usar 2 função juntas na mesma linha de código do VBA?

Outra pergunta:

A fórmula matricial {MULT(B1:B5+1))-1} funciona no Excel

Como usá-la no VBA?

Estou tendo dificuldades em usar fórmulas do Excel no VBA. Fórmulas simples tudo bem, mas quando é matricial ou 2 fórmulas juntas não consigo...

Alguém poderia ajudar?

Abraços!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: