Notifications
Clear all

formula para as quinzenas dentro de 6 meses  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
22/08/2009 12:29 pm  

Olá galera. preciso de uma ajuda.

Tenho uma plan que contem dados referente a venda de determinados produtos no período de 6 meses. 01/10/2007 a 31/03/2008.

Como faço para separar por quinzena, já está em ordem.
Tenho produto X, Y, W e por exemplo, quero o que foi vendido do produto X em: 01/11/2007 até 15/11/2007. ( não quero usar o filtro pq o volume é alto e acho que demora muito) tem outra saída?

Obrigado

Randro

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
22/08/2009 1:45 pm  


Supondo que a lista de produtos esteja em A2:A10, as datas da vendas estejam em B2:B10 e as vendas em C2:C10, pode fazer assim:

=SOMARPRODUTO(--(A2:A10="X");--((B2:B10>=39387)*(B2:B10<=39401));--(C2:C10))

Reforçando que, para os critérios, é melhor que estejam em células.

Obs: Os números 39387 e 39401 equivalem às datas do seu exemplo.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
22/08/2009 2:14 pm  

Obrigado Edson.

Vou testar sua formula.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
22/08/2009 2:47 pm  

Perfeito Edson.

Obrigado

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: