Notifications
Clear all

ERRO usando PROCV com 2 condições simultãneas  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
10/06/2010 10:25 am  

Caros Amigos, Boa Tarde.

Estou tentando ajudar uma amiga a criar uma planilha para procurar automaticamente o signo (horóscopo) da pessoa, baseado na data de nascimento.

Me desculpem se tem palavras em inglês na planilha.
É que ela mora em outro país.

No inicio da planilha criei uma tabela com o data de início e data de fim do periodo de cada signo e seu respectivo nome.

Ex.:
....A.........B...........C...........D................................
1.............STAR......END......SIGNS OF ZODIAC
2.............21/3......20/4......ARIES
3.............21/4......21/5......TAURUS
ETC..

Na parte de baixo tem uma lista de nomes de pessoas com as respectivas datas de nascimento e espaço para aparecer o signo.

Ex.:
.......A..................B.....................C...............................D................................
16...NAME.........Date of Birth.....Sign of zodiac
17.......................(dd/mm).................................................................
18...Person A..........21/3...........=PROCV(B18;$B$2:$D$13;3;1)
19...Person B..........22/4...........
20...Person C..........23/5...........
21...Person D..........22/6...........
22...Person E..........1/6...........
23...Person F..........2/4...........
ETC.

Dúvidas:

1) Não sei se estou usando a função mais adequada para este caso? eu pensei que sim.

2) A função retorna o signo certo na maioria dos casos, PORÉM, quando a data compreende os meses de JAN e FEV a fórmula devolve #N/D.
Quando usa o mês de DEZ é pior, ela devolve o valor errado.

Não entendo nada de horóscopo mas a tabela indica extamente qual signo deve ser baseado na data de nascimento.

Estou errando é na fórmula mesmo.

Alguém podeira, por favor, me mostrar o meu erro?
Pensei que seria simples mas me enrolei na fórmula. hi hi hi

Segue abaixo o link da planilha para melhorar a explicação.
http://www.4shared.com/document/lr8QEpbZ/2010--zodiac--test.html

Agradeço imensamente qualquer ajuda.

Daqui das bandas das Minas Gerais,

Boa Tarde, Mazzaropi.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


Citar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
10/06/2010 1:08 pm  

Troque o ano dos signos Aquario e Peixes para um a mais 2011

Use a formula SE(B18<=DATA(ANO(B18);2;21);DATA(ANO(B18)+1;MÊS(B18);DIA(B18));B18) para procurar

a formula ficara assim na celula C18 entao arraste para baixo
=PROCV(SE(B18<=DATA(ANO(B18);2;21);DATA(ANO(B18)+1;MÊS(B18);DIA(B18));B18);$B$2:$D$13;3;1)

segue a plan para download > download/file.php?id=429

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
10/06/2010 2:57 pm  

Caro leonardojones, Boa Tarde.

Muito Obrigado pela rapidez e pela precisão da sua ajuda. :P

Em momento algum eu pensei em trabalhar com o ANO, já que que o parâmetro principal é exclusivamente DIA e MÊS independente do ano.

Estudei a sua fórmula e compreendo agora que para trabalhar nesta tabela cíclica esta é a resposta certa mesmo.

Muito boa a sua solução!

Obrigado!

P.s: Fui informado que as datas estavam erradas e me enviaram as datas corretas dos períodos dos signos. Diante disto, fiz apenas um pequeno ajuste na sua fórmula para que ela funcionasse com as novas datas.
Mudei o mês e o dia da comparação:
Antes: Mês 2 Dia 21
Agora: Mês 3 Dia 20

Segue link com a planilha final: 2010--zodiac--test-RESOLVIDA.xls

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
10/06/2010 5:23 pm  

;)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: