Notifications
Clear all

Dúvidas com a Função SE  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
25/05/2010 6:37 pm  

• Crie mais uma coluna depois de Posição com o nome de Situação e atribua os
valores “Inesperada” se as vendas forem menores que 10.000,00 ou maiores
que 40.000,00. Em caso contrário, escreva “Normal”.
A Planilha é esta
http://www.imagebam.com/image/e9df7182014466

Segui o mesmo princípio da última Planilha e mesmo assim não dá certo

=SE(E(B22<10000)*(B22>40000);"Inesperada";"Normal")

Onde deveria ser "Inesperada" ficou normal, que seriam as Vendas Acima de 40000 e abaixo de 10000.
Onde Estou errando?

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
25/05/2010 6:40 pm  

• Crie mais uma coluna depois de Posição com o nome de Situação e atribua os
valores “Inesperada” se as vendas forem menores que 10.000,00 ou maiores
que 40.000,00. Em caso contrário, escreva “Normal”.
A Planilha é esta
http://www.imagebam.com/image/e9df7182014466

Segui o mesmo princípio da última Planilha e mesmo assim não dá certo

=SE(E(B22<10000)*(B22>40000);"Inesperada";"Normal")

Onde deveria ser "Inesperada" ficou normal, que seriam as Vendas Acima de 40000 e abaixo de 10000.
Onde Estou errando?

=SE(OU(B22<10000;B22>40000);"Inesperada";"Normal")

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
25/05/2010 6:47 pm  

• Crie mais uma coluna depois de Posição com o nome de Situação e atribua os
valores “Inesperada” se as vendas forem menores que 10.000,00 ou maiores
que 40.000,00. Em caso contrário, escreva “Normal”.
A Planilha é esta
http://www.imagebam.com/image/e9df7182014466

Segui o mesmo princípio da última Planilha e mesmo assim não dá certo

=SE(E(B22<10000)*(B22>40000);"Inesperada";"Normal")

Onde deveria ser "Inesperada" ficou normal, que seriam as Vendas Acima de 40000 e abaixo de 10000.
Onde Estou errando?

=SE(OU(B22<10000;B22>40000);"Inesperada";"Normal")

Antes de pedir ajuda e fiz deste mesmo jeito, talvez com um sinal diferente, mas interpretei deste mesmo jeito e deu errado.
rsrs
Mas Agora deu certo e agradeço a ajuda. É de muito útil este site, vc é 10
Valeu !!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
26/05/2010 2:01 pm  

Léo e Daniel.

O único probleminha era a interpretação matemática (Sinais), mas a parte de Excel vcs usaram corretamente.

Léo,

Poderia ser por essa fórmula tbm que daria no mesmo:

=SE(E(C6>10000;C6<40000);"Normal";"Inesperada")

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
26/05/2010 6:55 pm  

Léo e Daniel.

O único probleminha era a interpretação matemática (Sinais), mas a parte de Excel vcs usaram corretamente.

Léo,

Poderia ser por essa fórmula tbm que daria no mesmo:

=SE(E(C6>10000;C6<40000);"Normal";"Inesperada")

Uma coisa q não entendo é o seguinte:
Em uma planilha Sobre Peso achei o Peso idela de uma pessoa pela Fórnula:
=SE(C40="Masculino";72,7*D40-58;62,1*D40-44,7)
O valor achado foi 71

Este valor estando na célula F40 deve ser comparado com o valor da célula E40 (79KG), que seria o peso atual da pessoa
Ele estaria em forma se o Peso Atual fosse igual ao Peso Ideal
Ou seja:
=Se(F40=E40;"Em Forma";"Fora de Forma")
O problema é q o valor em F40 (71Kg) entra em contradição pois foi descrito como sendo a Função:
=SE(C40="Masculino";72,7*D40-58;62,1*D40-44,7)
Minha dúvida se resume a isso
E40 não é igual a F40 já q a mesma foi dada pela Função citada.
Pq isso acontece e como resolvo isso?

Peso (KG)-- Peso ideal ------Situação Critica
79 -------- 71 ---------- -Fora de Forma
62 ---------55 ----------- Fora de Forma
60 ---------63 ------------Fora de Forma
80 ---------80 ----------- Em Forma
70 ---------70 ----------- Em Forma

Deveria ser assim

Esta é diferente pq o valor a ser usado como base foi dado
Ex: A média terá q ser > ou = a 7. etc

Ajuda

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
26/05/2010 6:58 pm  

Léo e Daniel.

O único probleminha era a interpretação matemática (Sinais), mas a parte de Excel vcs usaram corretamente.

Léo,

Poderia ser por essa fórmula tbm que daria no mesmo:

=SE(E(C6>10000;C6<40000);"Normal";"Inesperada")

Uma coisa q não entendo é o seguinte:
Em uma planilha Sobre "Peso" achei o Peso ideal de uma pessoa pela Fórnula:
=SE(C40="Masculino";72,7*D40-58;62,1*D40-44,7)
O valor achado foi 71

Este valor estando na célula F40 deve ser comparado com o valor da célula E40 (79KG), que seria o peso atual da pessoa.
Ele estaria em forma se o Peso Atual fosse igual ao Peso Ideal
Ou seja:
=Se(F40=E40;"Em Forma";"Fora de Forma")
O problema é q o valor em F40 (71Kg) entra em contradição pois foi descrito como sendo a Função:
=SE(C40="Masculino";72,7*D40-58;62,1*D40-44,7)
Minha dúvida se resume a isso
E40 não é igual a F40 já q a mesma foi dada pela Função citada.
Pq isso acontece e como resolvo isso?

Peso (KG)-- Peso ideal ------Situação Critica
79 -------- 71 ---------- -Fora de Forma
62 ---------55 ----------- Fora de Forma
60 ---------63 ------------Fora de Forma
80 ---------80 ----------- Em Forma
70 ---------70 ----------- Em Forma

Deveria ser assim

Esta dúvida é diferente as outras pq o valor a ser usado como base foi dado e esta não, ele foi achado através de uma função.

Ajuda

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
27/05/2010 8:33 am  

Léo e Daniel.

O único probleminha era a interpretação matemática (Sinais), mas a parte de Excel vcs usaram corretamente.

Léo,

Poderia ser por essa fórmula tbm que daria no mesmo:

=SE(E(C6>10000;C6<40000);"Normal";"Inesperada")

Uma coisa q não entendo é o seguinte:
Em uma planilha Sobre "Peso" achei o Peso ideal de uma pessoa pela Fórnula:
=SE(C40="Masculino";72,7*D40-58;62,1*D40-44,7)
O valor achado foi 71

Este valor estando na célula F40 deve ser comparado com o valor da célula E40 (79KG), que seria o peso atual da pessoa.
Ele estaria em forma se o Peso Atual fosse igual ao Peso Ideal
Ou seja:
=Se(F40=E40;"Em Forma";"Fora de Forma")
O problema é q o valor em F40 (71Kg) entra em contradição pois foi descrito como sendo a Função:
=SE(C40="Masculino";72,7*D40-58;62,1*D40-44,7)
Minha dúvida se resume a isso
E40 não é igual a F40 já q a mesma foi dada pela Função citada.
Pq isso acontece e como resolvo isso?

Peso (KG)-- Peso ideal ------Situação Critica
79 -------- 71 ---------- -Fora de Forma
62 ---------55 ----------- Fora de Forma
60 ---------63 ------------Fora de Forma
80 ---------80 ----------- Em Forma
70 ---------70 ----------- Em Forma

Deveria ser assim

Esta dúvida é diferente as outras pq o valor a ser usado como base foi dado e esta não, ele foi achado através de uma função.

Ajuda

Como posso resolver isso?

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
27/05/2010 9:42 am  

Olá, Léo.

Bom, a dúvida principal do tópico foi resolvida. Esta é uma outra questão.
Para que não misturemos as coisas, peço, abrir outro tópico com uma descrição correta da dúvida e postar a planilha (não imagem) para facilitara a interpretação dos cálculos. ;)

Abraços,

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: