Notifications
Clear all

Dúvida para buscar e retornar o valor máximo  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
25/04/2010 6:51 pm  

tenho uma planilha com as colunas abaixo, que identifica o número de pedidos que foram feitos para as empresas, para cada estado. Preciso colocar na coluna "resposta que eu quero", alguma identificação do estado que fez mais pedidos em cada CNPJ. Desta forma, depois eu consiguirei aplicar um filtro e ter uma lista com o estado mais comprador de cada empresa.
Alguem sabe a formula que eu poderia colocar na coluna "resposta que eu quero?
-----CNPJ-----------estado------quantidade----resposta que eu quero

011222333000111-------RJ------------50------------------50------------
011222333000111-------MG-----------10----------------FALSO----------
011222333000111-------MT------------5----------------FALSO----------
099888777000199-------RJ------------20----------------FALSO----------
099888777000199-------ES-----------45-------------------45-----------
099888777000199-------CE-----------15-----------------FALSO---------
099888777000199-------AM------------4-----------------FALSO---------
554443334000133-------SP-----------65-------------------65-----------
554443334000133-------RJ------------40-----------------FALSO---------
554443334000133-------AM------------9-----------------FALSO---------

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
25/04/2010 8:48 pm  


Tenta esta, em D1, e após, arrastar:

=SE(MAIOR(SE($B$1:$B$10=B1;$C$1:$C$10;0);1)=C1;C1;FALSO)

Veja se o resultado é o esperado, caso contrário, indique em que ocorrência o retorno não atende.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
27/04/2010 6:47 pm  

Eu entendi assim....

=SE(C1=MÁXIMO(($A$1:$A$10=A1)*($C$1:$C$10));C1;"FALSO")
finalizar com shift+ctrl+enter ao inves de somente enter

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: