Notifications
Clear all

Dificuldade com fómulas!  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
20/08/2009 7:46 am  

Estou tendo dificuldade para obter a idade de uma pessoa só pela data de nascimento.
O esquema é este:

Data: 12/02/1980 (B7)
Idade: ?
Hoje: 10/08/2009 (E19)
=(HOJE()-"célula com a data de nascimento")
=ANO(E19;B7;"Y")
=DATADIF(B7;AGORA();"y")

MESMO ASSIM MEU RESULTADO É ERRO
Qual seria meu problema?

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


Citar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
20/08/2009 8:06 am  

Se for só para saber quantos anos a pessoa tem:

=ANO(HOJE())-ANO(A1) --> formate a célula para geral

=ANO(HOJE())-ANO(DATA(1980;2;12)) --> formate a célula para geral

obs: a dataif ou dif precisa ter o suplemento ferramenta de análise instalada (se não me engano).

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
20/08/2009 8:11 am  

Esta segunda deu certo
ANO(HOJE())-ANO(DATA(1980;2;12))

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
20/08/2009 8:12 am  

Qual problema que a primeira apresentou?

=ANO(HOJE())-ANO(célula da data de nascimento) --> formate a célula para geral

...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
20/08/2009 5:19 pm  

Elas já foram solucionadas mas antes dizia que foram inserido poucos caracteres.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
20/08/2009 5:36 pm  

Minha dúvida agora se resume a contagem de ítem iguais em células diferente.
Ex: Coluna D (sexo)
D7, D8, D10, D13, D14 , D15, ... (masculino)
Quero determinar o nº de ítem que sejam masculino e inserir em uma outra célula sem ter que ficar contando célula por célula.
Ex: Quantos ítens "masculino" existem? - (C18) será onde o resultado ficará
Quantos ítens femininos existe? (C19) =? resultado

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
20/08/2009 5:47 pm  


=CONT.SE(D1:D100;"masculino")
=CONT.SE(D1:D100;"feminino")

Adaptado ao seu intervalo.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
20/08/2009 6:19 pm  

Como determino o maior nº entre intervalos?
A célula que apresenta maior valor

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
20/08/2009 9:29 pm  

use a função MAIOR() ou a função MÁXIMO()

exemplo:
=MAIOR(A1:A1000;1)

ou

=MÁXIMO(A1:A1000)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
21/08/2009 8:25 am  

É importante saber os caracteres certo a serem usados. No caso da função MAIOR, não é "," e sim " ;" pois se não dá erro. Valeu pela ajuda, estão sendo de boa utilidade.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: