Notifications
Clear all

DIATRABALHOTOTAL  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
02/02/2010 11:41 am  

Olá pessoal!

Preciso saber se existe uma forma de o excel retornar o nº de dias úteis (considerando o sábado como um dia útil), a partir de uma célula com data inicial e outra com a data final.

Utilizei esta função, porém o resultado não é muito exato:

=DIATRABALHOTOTAL(B17;B18)+ARRED((DIAS360(B17;B18)-DIATRABALHOTOTAL(B17;B18))/2;0)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
02/02/2010 6:40 pm  

Para saber a quantidade de Sabados, vc pode fazer a seguinte fórmula....
=SOMA(SE((DIA.DA.SEMANA(DATA(ANO(C17);MÊS(C17);LIN(INDIRETO("1:"&C18-C17+1)));1)=(6-DIA.DA.SEMANA(C17;3)+1));1;0)) ctrl+shift+enter

A formula toda pode ficar assim....
=DIATRABALHOTOTAL(C17;C18)+SOMA(SE((DIA.DA.SEMANA(DATA(ANO(C17);MÊS(C17);LIN(INDIRETO("1:"&C18-C17+1)));1)=(6-DIA.DA.SEMANA(C17;3)+1));1;0)) ctrl+shift+enter

Segue planilha exemplo => download/file.php?id=315

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
02/02/2010 10:06 pm  

Poxa vida meu... Difícil, p/ um problema simples... Foi a dúvida de uma aluna minha... he he
Me ajudará muito!
Obrigado mais uma vez!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
04/02/2010 2:10 pm  

Para saber a quantidade de Sabados, vc pode fazer a seguinte fórmula....
=SOMA(SE((DIA.DA.SEMANA(DATA(ANO(C17);MÊS(C17);LIN(INDIRETO("1:"&C18-C17+1)));1)=(6-DIA.DA.SEMANA(C17;3)+1));1;0)) ctrl+shift+enter

O problema é que com esta fórmula acima só posso fazer em um período dentro de um único mês. E se eu precisar fazer num período que envolve mais de um mês???? Você tem alguma sugetão????

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
04/02/2010 4:19 pm  

Tem certeza?
Acabei de testar com 20 anos e a formula retornou TODOS os Sábados entre as duas datas!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
04/02/2010 9:05 pm  

testado, funciona muito bem

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
05/02/2010 6:11 am  

Tem certeza?
Acabei de testar com 20 anos e a formula retornou TODOS os Sábados entre as duas datas!!!

Bom dia!!!

Será que existe algum problema no meu excel, pois realmente não esta funcionando para mim?

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
05/02/2010 3:09 pm  

Tenta baixando essa plan!!!
veja se no seu PC a formula vai estar correta!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: