Notifications
Clear all

De horas para minutos  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
04/11/2009 5:08 pm  

E gostaria de uma formula para calcular os minutos de um periodo entre 14:48 as 00:15.

Sempre que tento aplicar uma formula desse caluco, se não ultrapassar as 00:00 funciona mai se ultrapassar da errado.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
04/11/2009 5:51 pm  

Tenta assim....
=SE(B1<A1;(B1+1)-A1;B1-A1)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
05/11/2009 4:33 am  

Sabendo que das 07:30 as 08:30 tem uma janta, como eu faço este calco para que apartir das 07:30 ele diminua uma hora e antes não

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
05/11/2009 11:49 am  

tenta assim...
=SE(B1<A1;(B1+1)-A1;B1-A1)-SE(OU(B1<A1;B1>(19,5/24));1/24;0)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
07/11/2009 5:13 am  

Leonardo você poderia me explicar esta parte da formula SE(OU(B1<A1;B1>(19,5/24));1/24;0)

Porque tem que aplicar a mesma nos horarios de
07:30 as 17:18 com almoço de 11:30 as 12:30
05:00 as 14:48 com almoço de 10:30 as 11:30
00:15 as 06:15.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
07/11/2009 11:42 am  

SE(OU(B1<A1;B1>(19,5/24));1/24;0)
Opa!!!
Podemos ler assim....
Se o valor da B1 for menor q o da A1 (é o caso de 00:15 1:10) OU o valor da B1 for maior q 07:30 da noite (19:30) o resultado será 1/24 se não o resultado será 0.

Pq 1/24???? O Excel reconhece os valores de horas como a hora dividido por 24....
Ex: Se vc colocar 12:00 em uma celula, depois ir em formatar / celulas / Geral o resultado é 0,5!!!! Nesse caso o resultado será 1/24 (se passar das 19:30 menos uma hora)

Pq 19,5/24???? Coloquei isso pra nao precisar digitar assim 0,8125 (q é o mesmo q 19:30 e tbem o mesmo q 19,5/24)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
08/11/2009 11:41 pm  

Quanto mais eu mexo mais coisa aparece para fazer

tem como incluir na formula acima o seguinte parametro.
que o resultado final seja multiplicado por 1440 porque assim o valor em horas seria comvertido em minutos.

E depois de convertido em minutos ser subtraido a celular seguinte a mesma que é onde vai ser computado o tempo de preparação, e esse tempo tem que ser subtraido do resultado final.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
11/11/2009 11:59 am  

=((SE(B1<A1;(B1+1)-A1;B1-A1)-SE(OU(B1<A1;B1>(19,5/24));1/24;0))*1440)/C1
onde C1 é a celula seguinte

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
11/11/2009 7:54 pm  

Leonardo tu esta me dando uma ajuda danada.

Da uma olhada nesta planilha, na linha 5 e 6 eu ja consegui fazer a redução da celula que eu queria só me resta fazer a conversão para minutos para que eu exclua a coluna que faz esta conversão de horas para minutos.

http://www.yousendit.com/download/TzY2R ... WGNLSkE9PQ

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
12/11/2009 1:18 pm  

Opa!!!
ve se é assim...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
12/11/2009 5:15 pm  

Muito obrigado cara, você me ajudou muito.

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
12/11/2009 9:03 pm  

Precisando é só gritar :D

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: