Notifications
Clear all

Classificação entre 3 campos diferentes  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
06/02/2010 9:55 am  

Olá pessoal,

Estou há dias tentando resolver uma solução para um estudo que preciso desenvolver na empresa. Tenho uma planilha com vários documentos que se repetem. Além dessa coluna, tenho mais duas com a data e a hora em que a solicitação para àquele documento foi aberta. Há alguma maneira de filtrar e trazer em uma célula, se o documento for o mesmo e a data de abertura for a mesma e o intervalo dessa abertura for em menos de 30 minutos, contabilizar como 1?

Desculpem se ficou meio confuso.

Obrigado desde já!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


Citar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
06/02/2010 2:16 pm  

Vai 2 maneiras pra vc escolher!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
06/02/2010 2:17 pm  

***Maneira 1***

Para saber quantos desse mesmo documento repetido vc tem...

Usando a formula...
=SOMA((A2:A15=E2)*(B2:B15=F2)*(C2:C15>=(G2-(30/60/24)))*(C2:C15<=(G2+(30/60/24)))) shift+ctrl+enter

Segue download da plan > download/file.php?id=321

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
06/02/2010 2:21 pm  

***Maneira 2***

Para filtrar e mostrar somente os não repetidos ou somente os repetidos...

Usando a formula...
=SE(A2="";"";SE(SOMA(($A$2:A2=A2)*($B$2:B2=B2)*($C$2:C2>=(C2-(30/60/24)))*($C$2:C2<=(C2+(30/60/24))))>1;"repetido";"listar")) shift+ctrl+enter

Segue download da plan > download/file.php?id=325

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
06/02/2010 4:35 pm  

Cara vc é fera!!! Valeu!!!!

Grande Abraço!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
06/02/2010 5:50 pm  

:D

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
20/06/2011 6:50 am  

Caro Leonardo,

Preciso de sua ajuda novamente. Seguindo esta mesma lógica de comparar 3 campos diferentes para verificar se repetem ou não, ao invés do intervalo da diferença ser de 30 minutos, preciso que seja identificado se a repetição ocorre até 24 horas depois, e em 7/15/30/60 dias . Tentei utilizar a fórmula matricial como vc mostrou, mas não obtive êxito. Pode me ajudar?

Obrigado!!
Abraço!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: