Notifications
Clear all

Marcar itens repetidos  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
23/11/2009 7:20 am  

Pessoal, bom dia.

Estou querendo inserir a seguinte condição em uma formatação condicional:

na coluna A, tenho uma sequencia de números. Se por algum motivo algum desses números se repetirem, a célula ficaria em vermelho. Basicamente é isso, mas tentei e não consegui de forma alguma.

Estou enviando uma planilha com um exemplo do que estou falando. Na coluna "A" esatá a sequencia numérica (com alguns números repetidos) para ser aplicada a formatação condicional, e na coluna "D" está um exemplo de como planejo q fique a célula (considerando que vários números poderão se repetir simultaneamente).

Desde já agradeço!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


Citar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
23/11/2009 10:26 am  

Vamos supor que vc tenha três numeros 1 (dois são repetidos, certo?)...
Se vc quiser destacar apenas os dois repetidos.....Selecione A1 até A30 (por exemplo) e coloque a seguinte fórmula na formatação condicional e pinte a cor!!!!
=CONT.SE($A$1:A1;A1)>1

Agora se vc quiser destacar os três numeros....coloque a seguinte fórmula!!!
=CONT.SE($A$1:$A$30;A1)>1
Altere o $A$30 para o quanto vc quiser na planilha ($A$1000 por exemplo)

*Obs: Nos temos um fórum aki para Formação Condicional....assim q vc der Ok, vou transferir esse tópico pra lá...caso tenha alguma outra duvida sobre formatação, abra um tópico novo lá, certo?
Precisando é só gritar!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
23/11/2009 1:57 pm  

ok, pode transferir.

a princípio não funcionou aqui comigo, pq no q ele conta quatro vezes o número 1, ele pinta a célula q tem o valor 4 também.

eu vou dar mais uma estudada nisso e amanhã descrevo direito a situação, ou mesmo coloco a a solução.

obrigado!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
23/11/2009 5:39 pm  

Sim....
funciona com todos os numeros e letras repetidos!!!!
Segue um Print da tela!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
24/11/2009 12:58 pm  

Sim, testei novamente colocando a fórmula a partir da célula a1 e deu certo!

vlw, obg!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Adriano Nogueira
(@adriano-nogueira)
Active Member
Entrou: 8 anos atrás
Posts: 19
10/07/2012 8:53 am  

A forma mais simples de se fazer è:
Selecione toda a linha ou coluna em que se encontram os valores, na guia início selecione formatação condicional/realçar regras das células/valores duplicados.
E se preferir escolha a cor que ficaram as células com valores duplicados
Espero ter ajudado!


ResponderCitar (Quote)
Compartilhar: