Notifications
Clear all

Dúvida com somas e Procv!  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
09/03/2010 5:21 pm  

Ola galera, curto muito o excel, mas to apanhando demais dele, vamo ve se vcs podem me ajudar:

Tenho em 1 linha várias células com a formula procv, cada celula tem sua formula. O Procv, quando não possui um resultado, aparece a seguinte mensagem #N/D, ou #valor!. ok.

No final dessa linha, queria somar todas as celulas que me trouxessem algum resultado válido (qualquer numero maior que zero) porém não estou conseguindo com a formula SOMA pq, se tiver alguma célula com #N/D ou #Valor!, a fórmula SOMA simplesmente não soma. heehhe

Qual outra fórmula posso usar? o SOMASE?

abs e valeu!!! ;)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
10/03/2010 8:04 am  

Use o ÉERROS() antes da sua formula dos PROCV()

Ficaria assim....
=SE(ÉERROS(sua_formula);"";sua_formula)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
11/03/2010 4:30 pm  

Valeu Leonardo, vou tentar aqui e ja dou uma resposta! Obrigado mesmo!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/03/2010 12:11 pm  

nada feito Leonardo, aparece a seguinte mensagem de erro:

"O valor inserido não é válido.
Outro usuário restringiu valores que podem ser inseridos nesta célula."

Leonardo, minha fórmula é a seguinte:

=PROCV(Dieta!$C$38;BD!$B$6:$AX$501;3;"FALSO")/100*Dieta!$I$38

como ficaria imbutindo ÉERROS nesta fórmula?
valeu!!! ;)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/03/2010 5:38 pm  

=SE(ÉERROS(PROCV(Dieta!$C$38;BD!$B$6:$AX$501;3;0));"";PROCV(Dieta!$C$38;BD!$B$6:$AX$501;3;0)/100*Dieta!$I$38)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
15/03/2010 3:27 pm  

Exato!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: