Notifications
Clear all

Retornar dias da semana em outros idiomas  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
07/10/2009 10:53 am  

Dica muito bacana postada no topico da comunidade pela Isabela, então resolvi postar aki!!!

Supondo que a celula A1 seja 07/10/2009 se colocarmos em outra celula a formula =TEXTO(A1;"ddd") o resultado será qua e se colocarmos mais um "d" na formula =TEXTO(A1;"dddd") retornará quarta-feira

Isso se o seu Windows for portugues!!!!
Se for ingles retornará Wed ou Wednesday

Para forçar o Excel a usar alguns outros idiomas podemos usar essa opção de formatação ;"[$-416]ddd"
Onde 416 é o idioma definido como portugues!!!!
Isso pode ser em uma fórmula, por exemplo, =TEXTO($A$1;"[$-416]dddd") ou pode ser no formatar / celulas / personalizado!!!

Isso tbem funciona para os meses "mmm" ou "mmmm"

Não conheço todos os recursos desta opção então vou mostrar alguns que andei descobrindo!!!
Usando o [$-400 é ingles
Usando o [$-401 é arabe
Usando o [$-403 é Catalão
Usando o [$-404 é chines
Usando o [$-406 é sueco/dinamarquês
Usando o [$-407 é alemão
Usando o [$-411 é japones
Usando o [$-414 é sueco/dinamarquês
Usando o [$-416 é portugues
Usando o [$-436 é holandês

Quem quiser comparar pra ver tem as escritas nesses dois sites!!!
http://pt.wikipedia.org/wiki/Dias_da_Se ... os_idiomas
http://pt.wiktionary.org/wiki/Categoria ... %C3%81rabe)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: