Trabalhando com dat...
 
Notifications
Clear all

Trabalhando com datas  

  RSS

Eron
 Eron
(@eron)
Admin Admin
Entrou: 12 anos atrás
Posts: 101
25/07/2009 9:12 am  

Vamos la:

Essa é a estrutura:

A1: 01/01/2009
A2: 01/12/2012

Como posso criar, na coluna B, uma lista automática com todos os meses entre a data da célula A1 e A2 ?

Eron
CRA/RS 27.563
Administrador Fórum Planilhando


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
25/07/2009 10:38 am  

=SE(DATAM($A$1;LIN()-1)>$A$2;"";DATAM($A$1;LIN()-1))

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Eron
 Eron
(@eron)
Admin Admin
Entrou: 12 anos atrás
Posts: 101
26/07/2009 9:49 am  

Leo,

Tentei esta sua solução mas não funcionou aqui.
Tentei também montar com um =Se, mas ai o problema foi fevereiro.

Eron
CRA/RS 27.563
Administrador Fórum Planilhando


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
26/07/2009 10:04 am  

Ve se eh assim mesmo no anexo...
se for, pode ser q nao iniciou a formula na linha 1 (B1 por exemplo)...
se for iniciar outra linha pode se trocar o LIN()-1 por LIN(A1)-1
=SE(DATAM($A$1;LIN(A1)-1)>$A$2;"";DATAM($A$1;LIN(A1)-1))
Nessa mostra todos os meses deste periodo...

agora se fosse mostrar todos os dias tbem...pode-se usar assim...
=SE($A$1+(LIN(A1)-1)>$A$2;"";$A$1+(LIN(A1)-1))

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Eron
 Eron
(@eron)
Admin Admin
Entrou: 12 anos atrás
Posts: 101
26/07/2009 10:12 am  

Nada... ao trocar a data ela perde a referência... muito estranho...

Eron
CRA/RS 27.563
Administrador Fórum Planilhando


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
26/07/2009 10:31 am  

Lembrei de algo.....
pra a função DATAM() funcionar....eh preciso estar abilitado o SUPLEMENTO - FERRAMENTAS DE ANALISE!!!

segue exemplo na plan!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
26/07/2009 11:26 am  

Indexando....
Ferramentas de análise no menu Ferramentas / Suplementos

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Eron
 Eron
(@eron)
Admin Admin
Entrou: 12 anos atrás
Posts: 101
26/07/2009 11:31 am  

Funcionando, ON THE AIR!

Valeu! :mrgreen:

Eron
CRA/RS 27.563
Administrador Fórum Planilhando


ResponderCitar (Quote)
Compartilhar: