Problemas com 01/01...
 
Notifications
Clear all

Problemas com 01/01/1900  

Página 1 / 2
  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
08/08/2009 4:00 pm  

Olá Galera, boa noite!

Desenvolvi uma tabela de "relógio de ponto" porém o funcionário trabalha a noite e vira o outro dia.
A dúvida é a seguinte: ele calcula normal entrada e saída, subtrai um menos o outro e coloca na célula o valor de horas extras.
Utilizando a formula SOMASE puxa a soma, pois existem 2 valores de hora, porém quando o funcionário trabalha de um dia para outro, a célula dá um problema, pois a soma não sai correta.
A celula apresenta o valor correto das horas extras só que com a data de 01/01/1900. Devido a isso em vez de somar (SOMASE) subtrai....
Tem como mudar esta data ??
Alguém poderia me dar uma dica?

Grato pela atenção

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
09/08/2009 5:30 pm  

Tá, deixa ver se eu entendi!

Vamos supor que:

A1 = 9/8/2009 22:00:00
B1 = 10/8/2009 05:00:00
C1 = =B1-A1

Para mim está aparecendo C1 = 0/1/00 7:00
Então é só ir em formatar célula: Personalizado:= [hh]:mm:ss

Bom pelo menos foi isso que eu entendi...

Att, Binario...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
10/08/2009 4:29 pm  

Obrigado meu amigo pela atenção...
Uso tudo na mesma linha...não chega a mudar de linha...
Ai quando no final utilizo a formula SOMASE ela não soma esta linha pq mudou de dia....

Caso queira posso lhe enviar uma cópia pra ver como ficou....

De qq forma mto obrigado....

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
10/08/2009 7:27 pm  

Se quiser pode postar neste HD Virtual!

http://www.4shared.com/

Assim outras pessoas poderão baixar e tentar lhe ajudar tbém...

Att, Binario

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
11/08/2009 11:20 am  

Isso mesmo, favor postar sua planilha que faremos o que for possível para ajudá-lo!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
11/08/2009 3:29 pm  

Ok amigos, mto obrigado até o momento...

http://www.4shared.com/file/124431457/f ... ponto.html

O problema é nos dias: 25 e 26 quando passa da meia noite !!!!

Grato

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
11/08/2009 5:12 pm  

Boa Noite!

Seria isso:

I26 =SE(D26>C26;D26-C26;"24:00:00"-C26+D26)+SE(F26>E26;F26-E26;"24:00:00"-E26+F26)+SE(H26>G26;H26-G26;"24:00:00"-G26+H26)

http://www.4shared.com/file/124450641/3163d37b/Plan_ponto__Binario_.html

Att, Binario

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
11/08/2009 7:21 pm  

Meu amigo, muito obrigado....me ajudou e muito...mas mto mesmo...

Vc és um gênio mesmo em excel, parabéns pela façanha...e mto sucesso...

abraços

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
11/08/2009 7:43 pm  

Hehe.. não é pra tanto.. :oops:

Precisando estamos a disposição!!!

Mas o fato de vc mandar o arquivo facilitou o entendimento da sua necessidade! (Y)

Abraços!!!

Att, Binario

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
12/08/2009 5:26 pm  

Meu amigo preciso novamente de sua ajuda em outro ponto, tem como analisar para mim?
Está escrito ao lado da tabela...qq dúvida fico a disposição...

http://www.4shared.com/file/124670942/9 ... rio_2.html

Novamente obrigado

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
12/08/2009 6:17 pm  

Tenta assim....

Na coluna J
=SE(I2-DIA(I2)<=B2;" ";I2-DIA(I2)-B2)

Na coluna K
=SE(I2-DIA(I2)>=B2;" ";B2-(I2-DIA(I2)))

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
12/08/2009 7:10 pm  

Obrigado meu amigo, deu certo aqui..valew

muito obrigado...

Enfim obrigado a todos que me ajudaram........

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
13/08/2009 6:41 am  

Amigo!

Poste em um outro HD Virtual, porque aqui na empresa eu não tenho como acessar o 4Shared.

Assim posso te ajudar!

abraço!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
15/08/2009 12:14 pm  

Meus amigos...só mais uma ajudinha para que eu possa concluir minha planilha de horas....

http://www.4shared.com/file/125249589/a ... io_21.html

Está marcado na planilha o problema....

mais uma vez muito obrigado

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
15/08/2009 1:15 pm  

Boa tarde!

Uma seria assim:

L33 =SE(K33>J33;"("&HORA(ABS(K33-J33))&":"&MINUTO(ABS(K33-J33))&")";J33-K33)

L34 =SE(K34>J34;"("&HORA(ABS(K34-J34))&":"&MINUTO(ABS(K34-J34))&")";J34-K34)

Att, Binario!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Página 1 / 2
Compartilhar: